Old browser warning

Site look funky?  Your browser is either Internet Explorer (hit refresh (F5) several times due to a bug in Microsoft's code that we can't work around) or is 10 years old and standards-based layouts and styling confuse it.   Consider updating.  One excellent option is Mozilla Firefox, versions of which are available for Linux, Mac and Windows. Safari 1.0+ and IE 6.0+ are also supported.

posted April 15, 2009
by Jeffrey Paine

 

  Member Website User
Post photos and video
Receive AW Beta
Protect rivers and river access  
Receive AW Journal  
Exclusive vendor discounts  
10% discount in AW store  
Download AW Journal  
     
 Join as: Join or Renew
   Just $35 a year!

*Already an AW Member? Select

“Website User” and you will have

the option to link it with your

existing Membership Account.